Web App down
Incident Report for Clever Elements
Resolved
This incident has been resolved. The web app is now back up and available.
Posted about 3 years ago. Sep 22, 2016 - 17:18 CEST
Update
Still investigating. We will update you again in 30 min latest.
Posted about 3 years ago. Sep 22, 2016 - 17:07 CEST
Investigating
Our web app is currently down, we're working to resolve this.
Posted about 3 years ago. Sep 22, 2016 - 17:04 CEST