Delayed Delivery
Incident Report for Clever Elements
Resolved
This issue has been resolved.
Posted almost 3 years ago. Oct 26, 2016 - 16:06 CEST
Monitoring
We have identified and fixed the problem. Currently monitoring.
Posted almost 3 years ago. Oct 26, 2016 - 15:44 CEST
Investigating
We are currently experiencing delayed delivery for some mailings and are investigating.
Posted almost 3 years ago. Oct 26, 2016 - 15:29 CEST